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Getting started

You will need a copy of DIMPLE 3.0 (either a demonstration copy or licensed copy) and the sample
images from the demo CD to follow this guide.

The sample images are found on the demo CD in the folder “DIMPLE Demo Images” (Macintosh) or
the folder “DEMOIMG” (Windows), and take up about 15 MBytes of disk space.  You may wish to
copy this folder from the CD to your hard disk for better performance.

Mac OS: Make sure your system is set to “thousands” or “millions” of colours mode using the
Monitors control panel.  Launch DIMPLE by double clicking on the DIMPLE icon in the DIMPLE
folder.

Windows 95, Windows NT 4: Make sure your monitor is set to “High color (16 bit)” or “True color (24
bit)” using the Display control panel.  Launch DIMPLE by choosing the DIMPLE icon from Programs
in the Start menu.

Windows NT 3.51: Make sure your monitor is set to “65536 Colors” or “16777216 Colors” using the
Display control panel.  Launch DIMPLE by double-clicking on the DIMPLE icon in the DIMPLE
program group.

Windows 3.1: Set your monitor to 16 bit (high colour) or 24 bit (true colour) mode using the control
panel or utility for your video card.  Launch DIMPLE by double-clicking on the DIMPLE icon in the
DIMPLE program group.

1. Smoothing filters

The first example illustrates one use of the rank filter.  It aims to remove transmission noise from an
image of the moon, transmitted from a space probe to Earth.  The field of digital image processing
originally grew out of this type of application during the 1960’s; similar techniques have more recently
been used to process images from the Hubble Space Telescope, Magellan Space Probe, and Voyager
probes.

1. Choose Open from the File menu.  Move into the folder containing the DIMPLE sample images.
Open the image “Moon.DIM”.  Notice the transmission noise.

2. Choose Rank Filter from the Enhance menu.  Use a 3x3 median filter - a 3x3 rank filter with rank
5.  Click on OK.  Compare the original and filtered images.

3. Click on the original Moon image to bring it to the front.  Choose Filter from the Enhance menu
and then Specify from the submenu.  This dialog box allows you to specify a custom filter for use
with DIMPLE.  You can choose the size of the filter, from 3x3 to 9x9, the coefficients for the filter,
and conditions under which the filter will be applied.

Low-pass filtering
Specify this filter:

1 1 1
1 1 1
1 1 1

/ Denominator: 9

Click on Filter to apply the filter to the image.
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Conditional filtering
Again, choose Filter from the Enhance menu, and Specify from the submenu.  The filter you
specified above is displayed again.

Check the Condition box and experiment with different conditions in conjunction with the above
low-pass filter - for example “pixel value inside 254” will filter out all the white spikes in the
image, which have a value of 254.

4. Choose Close all from the File menu when finished.

2. Digital convolution filters

The next two examples illustrate the use of digital convolution filters to achieve different effects.  Both
of the filters used here aim to operate on edges - either for edge detection or edge enhancement.

1. Open the image “Jet.DIM” (using Open from the File menu).

Laplacian Edge Detection

2. Choose Filter from the Enhance menu, then Specify from the submenu.

You can save filters which you use frequently; if you save your filters in the “Filters” folder
located in the same folder as the DIMPLE application, these filters will be listed in the Filters
submenu.

Click on the Loadbutton, and then select the filter “Laplace.FIL”.  This is a Laplacian filter which
is used for edge detection.

3. Click on the Filterbutton, and compar e the filtered image with the original image.   You can
specify other filters to detect edges running only in a certain direction - e.g. only horizontal
edges.

Edge Enhancement

4. Click on the original Jet image to bring it to the front.  Again choose Filter from the Enhance
menu, and Specify from the submenu.  Load the filter “Sharpen.FIL”.  Click on Filter.

5. Compare the filtered image to the original image.  Notice particularly the increase in local contrast
around the figures on the jet’s tail, and around the edges of the jet.

Enhancing part of an image

You can use enhancement tools such as filters on part of an image.  In this example, a high-pass filter
is used to enhance the writing on the side of the jet.

6. Click on the original Jet image to bring it to the front.  Click on the rectangular area selection tool

.  Select a rectangle around the writing “US AIR FORCE” on the side of the jet.   Again

choose Filter from the Enhance menu, and Specify from the submenu.  The sharpening filter
which you used in the previous step will still be displayed.  Click on Filter.
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7. A filtered image containing only the selected area is produced.  Choose Replace in “Jet” from the
Edit menu to replace the filtered writing in the original image.  Bring the original Jet image to the
front, and notice the change.  You can undo the change by bringing the original image to the front
and choosing Undo Replace from the Edit menu.

8. Choose Close all from the File menu when finished.

3. Contrast enhancement

The next few examples illustrate the use of the Histogram tool to perform histogram modifications to
increase contrast in an image.

1. Open the image “Girl.DIM”.  Notice the low contrast in the image.

2. Choose Histogram from the Analyse menu, then Pixel Values from the submenu to obtain an
image histogram.  Compare the cumulative and frequency representations by clicking on the
buttons marked “f” and “∑”.  Note that the minimum and maximum pixel values in the image
are displayed above the Apply button.

Linear Stretch

3. Note that by default a linear stretch across the range of pixel values 0 to 255 is chosen.  Click on
the Apply button.  Notice the increase in contrast.  Click on Revert.

Saturation

4. Click on the lower saturation arrow, and drag it to the right to a saturation limit, as shown below.

Similarly, click on the upper saturation arrow, and drag it to the left.  (Saturation limits should be
around 124 and 157.)

5. Click on Apply and notice the effects of a saturated linear stretch.

6. When finished, click on Revert, drag the lower saturation arrow back to 0, and the upper saturation
arrow back to 255.

You can also specify saturation limits as a number of standard deviations around the mean, or as
a percentage range, using the “±n std devs” and “Percentage” radio buttons.

Equalisation

7. Choose Equalise from the transform method pop-up list.
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Mac OS Windows

8. Click on Apply.  Notice the effect on the image.  Click on Revert when finished.

Gaussian stretch

9. Choose the Gaussian method using the transform method pop-up list, then click on Apply.  Notice
the effect on the image.  Experiment with different numbers of standard deviations by typing
values into the Std deviations box: type “1” then click on Apply; then type “6” and click on
Apply.  Notice the effects of different standard deviations.  Click on Revert when finished.

Exponential stretch

10. Choose the Exponential method using the transform method pop-up list, then click on Apply.
Notice the effect on the image.  Change the value of the Exponent by typing different values:
type “2” then click on Apply; then type “0.5” and click on Apply.  Experiment with lower and
higher values of the Exponent and observe the result.  Click on Revert when finished.

Histogram shift

11. Choose Shift using the transform method pop-up list.  Click on the histogram and drag right or
left; this has the effect of adding or subtracting a constant from each pixel in the image, brightening
or darkening the image.  Click on Revert when finished.

Piecewise Linear Stretch

12. Choose Piecewise Linear using the transform method pop-up list.  A line showing mapping of
pixel values to transformed values is shown.  You can add breakpoints to this line by clicking,
and move them by dragging.  To see the results of the transform, click on Apply.  Experiment
with different breakpoints.  Piecewise linear stretch is useful when an image has two distinct
areas, each of which is to have a different stretch applied to it.  Click on Revert when finished.

13. Choose Close all from the File menu when finished.

You can also use the histogram to manipulate the colour channels of a colour image in 8, 16, or 24 bits.
An example of this is described later in this guide.
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4. 3D Plotting

This example illustrates the use of 3D plotting on digital terrain data.  The values in all images used
up to now have represented light intensity; the values in one of the images in this example represent
altitude.  The 3D plot indicates the landform in the image.

1. Open the image “Jervis Bay.DIM” (Macintosh) or “JB.DIM” (Windows).  This is a Landsat Thematic
Mapper (TM) image of Jervis Bay, in New South Wales, Australia.

Multibands

2. Note that this is a multiband image consisting of several numbered and auxiliary channels.  The
numbered channels listed in the top pane of the window are statistically important for multiband
operations such as classification (demonstrated later in this guide).  Auxiliary channels contain
additional information about the image which you do not want to use in such operations.  The
numbered channels in this multiband are the Landsat TM bands.  Select the auxiliary channel
“Elevation” by double-clicking in the multiband window to the left of the channel name.  Type
return or enter to bring the window to the front.  This channel contains digital terrain data
representing altitude.

Working with images from disk

3. If you do not have enough system memory to work with large images or multibands with many
channels, DIMPLE allows you to leave the raster data for images on disk and still operate on

them.  The in memory icon:  at the bottom of the image window indicates the image is currently
in system memory.  Click on the in memory icon to free up the system memory being used by the

image.  The icon changes to an on disk icon:  .  If you bring another window to the front and
then bring “Jervis Bay:Elevation” to the front again you will notice it takes longer to update the
image (the difference is small for such a small image).  This is because the data is being read from
disk.  You can still operate on disk based images; however operations will be slower than if the
image was memory based.

Using an image on disk from a slow medium such as a CD-ROM is not recommended.

4. For channel images you can also click on the in memory/on disk icon displayed for each channel
in the multiband window; or move all channels or all numbered channels only into memory or
onto disk in one step.  Click on the multiband window to bring it to the front.  Move the numbered
channels of the multiband onto disk by holding down the shift key and clicking on the on disk
icon at the bottom of the multiband window.  Hide the numbered channels of the multiband by
holding down the shift key and choosing Hide all channels from the Image menu.  Bring the
channel image “Jervis Bay:Vegetation” to the front.  Click in the close box of the window.  Note
that clicking the close box of a channel image hides the channel; hidden channels are still part of
the multiband and available for processing.
Click on the in memory icon at the bottom of the multiband window to move all channels back
into memory.

RGB Colour Composite

5. In this step we produce an RGB colour composite image with different colours representing the
different features in three of the channels.  An RGB colour composite often helps provide better
definition of features.
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Choose RGB from the Transform menu.  Use the pop-up lists to assign the channels to colours as
follows:

 “Jervis Bay:TM5 mid IR 1.55 - 1.75µm” to red;
“Jervis Bay:TM4 near IR 0.76 - 0.90µm” to green;

and “Jervis Bay:TM3 red 0.63 - 0.69µm” to blue.

You can also specify a stretch to be used for each channel in the colour composite, using the
Stretch pop-up lists.  Leave these at “Current”.

You can produce a colour composite in 8-, 16-, or 24-bit colour.  24-bit images usually give the
best colour definition.  16-bit images potentially have lower definition, but take less memory.

Click on OK.  An RGB colour composite image is produced.  Because we didn’t use a stretch on
the channels above, the colour composite has low contrast.  You will now use the colour
components histogram to change the contrast of the image.

6. Choose Histogram from the Analyse menu, then Colour Components from the submenu.  The
colour components histogram is displayed.

Click on the “R” button to see the histogram for the Red channel.  Choose a Linear stretch with a
Percentage range of 1-99% by clicking on the Percentage radio button.  Click on the Apply button,
and the Red channel of the image is transformed.

Repeat this for the Green and Blue channels.  You will have produced a colour composite image
with much better colour definition.  You can also manipulate the colours of the image in Hue-
Saturation-Intensity space or Cyan-Magenta-Yellow space using the Method radio buttons above
the histogram.

To close the histogram, click on the Close box (Macintosh, Windows 95, and Windows NT 4) or double
click on the system menu at the top left of the window (Windows NT 3.51, Windows 3.1).

3D plotting

7. Bring the multiband window to the front, and then double click on the “Elevation” channel to
select it.  This image represents elevation.  You can improve the contrast in the image using a
pixel values histogram.

Choose 3D Plot from the Transform menu.  Click on the Composite button.  Choose “Jervis
Bay:Vegetation” from the Colour pop-up list.

Specify 50 intervals by typing “50” into the box labelled Intervals.  This specifies the resolution
of the 3D plot.

With the pixel values only ranging from 0 to 17 a somewhat “flat” 3D plot will be produced.  You
can exaggerate the “bumpiness” of the plot by specifying a scale factor of 5 for the z-axis by
typing “5” into the box labelled Z-Scale.  Click on OK.

8. Note that the colours from the channel image “Jervis Bay:Vegetation” are draped over the plot.
Once the plot has been produced, it can be re-oriented.  Click on the plot window, and hold the
mouse button down.  A small plane like this:

rotation

inclination
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will appear at the top left of the window.  Drag the mouse up and down to change the inclination
of the plot and left and right to change the rotation of the plot; the angles of inclination and
rotation are displayed at the top left of the plot window; the small arrow on the plane represents
the top of the original image.  Release the mouse button to replot the image with the new
orientation.

9. You can change the parameters used for the 3D plot by bringing the 3D plot window to the front,
and again choosing 3D plot from the Transform menu.

Try:

• Exaggerating the scale of the 3D plot by choosing a Z scale of 10 or 15

• Draping the RGB image you produced in the previous step by choosing it from the
Colour pop-up list.

• Changing the resolution of the plot by choosing a different number of intervals.
10. When finished, close the 3D plot window.

5. Using Vector Data

DIMPLE can import vector data in .DXF format.  You can overlay vector images onto raster images to
verify location of features, and you can use a vector image as the “master image” when performing
image-to-image registration.

1. Open the images “Rivers.DVE” and “Roads.DVE”.  These are vector images which have been
imported into DIMPLE from .DXF files, and saved as DIMPLE vector files.

Add these images to the Jervis Bay multiband using Add to Multiband from the Image menu,
and name them Rivers and Roads.

Bring the Jervis Bay RGB image to the front.  Choose Image overlay from the Annotation menu.
Choose “Rivers” from the Add vector pop-up list, then click on Apply.  The river vector image is
drawn over the RGB image.

Changing vector colours & order

2. Click on the colour box, labelled “None” next to “Rivers” in the Image overlay dialog box.  Choose
a colour like light blue from the dialog box which appears.  Click on Apply.  The river layer is
now redrawn in the selected colour.

3. Overlay the vector image “Roads” in the same way and choose a colour for it.

4. Click on the name for the vector layer “Roads” in the overlay vectors dialog box.  Use the arrow

control   to move the vector layer up, then click on Apply.  The roads layer is moved up, and

is now drawn closer to the front.

5. Choose Close all from the File menu when finished.
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6. Image Operation Language

The Image Operation Language (IOL) is a specialised programming language for implementing new
image operations.  The following  examples illustrate some of the capabilities of IOL.

Image Complement

The first example aims to change the jet image on which we earlier performed an edge detection so
that the edges are displayed in black and the background in white.

1. Open the image “Jet-Edges.DIM” (Macintosh) or “JETEDGE.DIM” (Windows).  This is the Jet
image with an edge detection filter applied, as demonstrated earlier in this guide.

2. Choose Open IOL from the Transform menu.  Open the file “Negative.IOL”.  Look at the IOL
program to see how this operation will work.

3. Choose Run from the Transform menu.  A dialog  box will ask which image you want the operation
to act on; since there is only one image, just click on OK.

4. Compare the new image with the original image.  Choose Close all from the File menu when
finished.

❖ Note:  if you have a “IOL” folder in the same folder as your DIMPLE application, any IOLs
in this folder will appear in the IOL submenu on the Transform menu (this is to allow you
quick access to frequently used IOL programs).

Unsharp Mask

IOL can be used to combine filters and other operations.  A well-known sharpening technique relies
on the observation that subtracting a smoothed version of an image from the image will leave only
edges.  By adding this difference back onto the original image, the edges are enhanced.

We will apply this technique to the Jet image, introduced at the beginning of this guide.

1. Open the image “Jet.DIM”.

2. Choose Open IOL from the Transform menu, and open the IOL program “Unsharp Mask.IOL”
(Mac OS) or “UNSHMASK.IOL” (Windows).  Note how the program specifies a low-pass filter,
and then adds the difference between this and the original image back to the original image.

3. Choose Run from the Transform menu.
Note the sharpened version of the image.

Choose Close All from the File menu when finished.

Vegetation Detection

The next example aims to detect vegetation from two satellite images, one showing the amount of
reflected red light, and the other the amount of reflected infra-red.  The image is of Wollongong, New
South Wales, Australia.

1. Open the multiband image “Wollongong.DIM” (Mac OS) or “WGONG.DIM” (Windows).

2. Choose Open IOL from the Transform menu.  Open the file “Vegetation.iol” (Mac OS) or
“Vegetate.IOL” (Windows).  This IOL program operates on two images, and produces two output



DIMPLE 3.0 Demonstration Guide Page 11

images - a Normalised Difference Vegetation Index (NDVI), and a Transformed Vegetation Index
(TVI).  Examine the program to see its structure.

3. Choose Run from the Transform menu.  Use the pop-up lists to associate “Wollongong:Red”
with Red and “Wollongong:near IR” with Infra-red.

For the Output data type, choose 32 bit real.  DIMPLE can operate on a variety of data types,
including 8, 16, and 32 bit integer, and 32 bit real.  This operation will produce a vegetation
indices in the range -1 to 1.

For the Stretch for display, choose “Linear 1-99%”.

Click on OK.

4. Notice the production of the two images - the vegetation index, and the transformed vegetation
index.  These are real images, so as you move the mouse over the image, the actual value of the
vegetation index is displayed in the Info window.  Different types of vegetation are shown as
different shades of grey.

In the next section, we will use density slicing to analyse the vegetation index images just produced.

7. Density Slicing

Density slicing involves partioning an image into contiguous pixel ranges, and assigning a colour to
each pixel range.    This example uses the NDVI image.

1. Bring the image “NDVI” to the front.

2. Choose Density Slice from the Analyse menu.  The Density Slice window appears, showing a
histogram for the image.  Underneath the histogram is the slice area, used for choosing slice
boundaries; and the colour area, used for choosing colours for each slice.

3. Click on the slice area to add new slices.  You can move a slice boundary by clicking on it and
dragging it, or delete a slice by extending an adjacent slice over it.  As you create slices, a default
colour is assigned to each slice (a shade of grey), and the image window updated.

You can also specify slice intervals by typing them in the slice values box.  When you make
changes here, buttons marked with a tick and a cross appear; click on the tick to accept your
changes.

4. You can change the default colour scheme by choosing a different CLUT.  Choose CLUTs from
the Enhance menu, then Colour scale from the submenu.  The colours used for the slices will
range between violet (low values) and red (high values)

5. You can specify a colour for a slice.  Click on the colour area below the slice, and choose a colour
from the dialog box.

6. Experiment with different slice intervals by clicking and dragging on slices in the slice area.  The
example on the next page gives good results for the NDVI image.

7. You can add a density slice key to the image, showing the colours for each range of values.  To do
this, bring the NDVI image to the front, and choose Add annotation from the Annotation menu,
and then Density slice key from the submenu.  You can specify the format of the density slice
key - the number of columns, size, and location.

8. You can create a classified image from the density sliced image.  To do this, click on Replot.  A
new image window is created with contiguous pixel values.  You can use the post-classification
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Density Slicing - Windows

Density Slicing - Mac OS
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editor to edit labels for each slice, and use the Class Key command to attach a class key to the
sliced image.  If you add the new image to the Wollongong multiband (using Add to Multiband
from the Image menu), you can use any of the post-classification analysis tools described in the
previous section to analyse the image.

9. Choose Close all from the File menu when finished.

8. Supervised classification

This example demonstrates the facilities provided for performing a supervised classification of an
image.

1. Open the multiband image “Cairns.DIM”.  This image shows Landsat MSS data of Cairns in
Northern Queensland, Australia.

Principal components

Producing an RGB colour composite can help to distinguish features in the image when producing
training areas.  In this example, we will produce a colour composite of the first three principal
components of the Cairns image.

2. Choose Principal Components from the Transform menu.  We want the first 3 principal
components, so specify “3”.  For the Output data type, we will use “Same as input” - i.e. 8-bit
integer.  Specify a “Linear 1-99%” Stretch for display.  Click on Generate principal components.

Examine the three principal components images to see what features are best shown in which
principal components.

3. Choose RGB from the Transform menu.  For the channels, use:
“Cairns PC-2” for Red;
“Cairns PC-1” for Green;

and “Cairns PC-3” for Blue.

Choose a 24 bit RGB, and click on OK.

Note that the various features of the image are easier to distinguish than in any of the component
channels.

4. Choose Add to Multiband from the Image menu, and add the RGB image to the Cairns multiband.
Close the principal components images, since they are not needed any more.

Training areas

Important: if you haven’t already copied the demo images from the CD to your hard disk, you will
need to copy the folder “Cairns Training Sets” (Mac OS) or “CAIRNSTS” (Windows) from the demo
images folder to your hard disk in order to follow this section.

5. Click on the rectangular area selection tool: .  Select an area of water from the RGB composite

image.  Notice that as the mouse moves over the image, a pixel vector graph is displayed in the info
window at the left of the screen, indicating the pixel values in each of the four component
numbered channels.
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6. Choose Collect Statistics from the Analyse menu.  A statistics window appears showing a

histogram and statistics for the area selected.  Click on the arrows:  to see the statistics for each

numbered channel.

7. Choose Apply Statistics from the Analyse menu.  Click on New to create a new training set.
Give it the name “Water training set”.  Click on the box next to “With theme” and specify a colour
for the new training set (e.g. blue).  Move into the folder “Cairns training sets” (Mac OS) or
“CAIRNSTS” (Windows), and click on Save.

8. Choose Edit training sets from the Analyse menu.  A dialog  box will be displayed asking you to
move into the folder containing the training sets; move into the folder “Cairns training sets”
(Mac OS) or “CAIRNSTS” (Windows), and click on OK.  The Training Set Editor window will
appear listing all the training sets in this folder; click on the training set that you created in step
5.  Examine the statistics for the various channels by using the Channel pop-up list to select a
channel.

Click on the box next to Theme, and choose a colour for the class from the colour picker dialog
box.  To modify the training set name, type the new name in the text box labelled Name.  To save
changes you have made to your training set to disk, click on Save Changes.  Click on the close
box to close the Training Set Editor window.

Training set cross plot

9. A training set cross plot will allow you to graphically observe the separation between training
sets.  Choose Cross Plot from the Analyse menu then Training Sets from the submenu.

10. Move into the training sets folder, and click on OK.

11. Click on Select All to select all training sets.  Choose 2 Std Dev from the Plot Type pop-up list.
Click on OK.

12. Move the mouse over the training set means.  Notice that the name of the training set under the
mouse is shown in the info window at the left of the screen.

13. Click on the close box to close the Training Set Cross Plot window.

Performing the classification

14. Click on one of the channels of the multiband to  bring it to the front.  Choose Supervised
classification  from the Analyse menu.

15. Move into the training set folder named “Cairns Training Sets” (Macintosh) or “CAIRNSTS”
(Windows), and click on Select current.
Select Euclidean as the method of supervised classification.

Click on Select All to select all the training sets.  Scroll down to the training set “Water training
set”, which you created earlier, and click on it to deselect it.

Click on Classify.  The classification may take some time to complete, depending upon the speed
of your computer.
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Post-classification analysis

16. The next few steps demonstrate the tools available in DIMPLE for analysing a classification.
These tools may be applied to any classified image in DIMPLE - for example unsupervised
classifications.

Move the mouse over the classified image.  Notice that the name of the class under the mouse is
shown in the info window at the left of the screen, as is the pixel vector graph.

Classified image class key

17. To add a class key choose Add annotation from the Annotation menu, and then Class key from
the submenu.  You can specify the format of the class key - the number of columns, size, and
position relative to the image.  Click on OK.

To change the font of the class key, ensure that the pointer tool    is selected, and click on the

class key.  Choose Text style from the Annotation menu, and choose an appropriate font.

Post-classification report

18. Make sure the classified image is the current window and choose Report from the File menu
then Post-classification from the submenu to produce a post-classification report.    There will be
a wait of a minute or so while statistics from the classification are calculated.  Scroll through the
report to see details of the classification that was just performed.

Class cross plot

19. Bring the classified image to the front and then choose Cross Plot from the Analyse menu, then
Image Classes from the submenu.

20. Click on Select All to select all classes.  Choose “Band 4” for Channel X, “Band 5” for Channel Y
and Pixel Value from the Plot Type pop-up list.  Click on OK. to produce the cross plot

21. Move the mouse over the image.  Notice that the name of the class under the mouse is shown in
the info window at the left of the screen.

22. Click on the close box to close the Image Class Cross Plot window.

Class canonical variates cross plot

23. A class cross plot shows the class separation in the two channels selected for the plot.  A cross
plot of canonical variates can show the class separation among all channels.
Bring the classified image to the front and then choose Cross Plot from the Analyse menu, then
Image Classes CV from the submenu.

24. Before the cross plot can be produced a canonical analysis is used to obtain statistics on class
separation.  Click on Select All to select all classes for the canonical analysis.  If you want to see
a report detailing the statistics for the canonical analysis, check the Produce report and Include
statistics boxes.  Click on OK.

25. Once the canonical analysis is complete, you select the classes which are to appear in the cross
plot.  Click on Select All to select all classes, and then click on OK.
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Each of the points shown on the canonical variate cross plot represents a class; its distance from
other points represents the distance in multispectral space from the other classes.

26. When finished with the image class canonical variates cross plot, click on the close box to close
the Cross Plot window.

Class editing

27. The DIMPLE class editor allows you to, among other things, interactively view the results of a
classification, and change such features as class names and theme colours.  To use the class editor,
first bring the classified image to the front and then choose Edit image classes from the Analyse
menu.

28. The Post-Classification Editor window will appear.  Note the list of classes along with theme
colours.  You can view the statistics for a class by clicking on it; use the Channel pop-up list to
look at different channels.

29. To change the name or theme colour for a class, first click on it - for example, click on “Suburban”.
Click on the colour box labelled Theme, and choose a different colour for the “Suburban” class.
You can also change the name by typing a new one in the text box labelled Name - e.g. “City”.  To
apply your class changes permanently to the classified image, click on Apply Changes.

30. Choose Close all from the File menu when finished.

9. Image Rectification and Registration

This example demonstrates the facilities provided for rectification of an image and for registering an
image to a map coordinate system.  The image used in this example is the RGB composite we produced
earlier from the Jervis Bay image.

1. Open the image “Jervis Bay RGB.DIM” (Mac OS) or “JBRGB.DIM” (Windows).

Setting up the GCP model

2. Choose New GCP model from the Image menu.

3. Choose the coordinate system for the image.  Click on the Coord system button.
DIMPLE supports projected, geographic, and user-defined coordinate systems.  Jervis Bay is in
New South Wales, Australia, and will use the Australian Map Grid (AMG) system, based on
Australian Geodetic Datum 1966 (AGD66).  Click on Projected, and then choose “AGD66/AMG”
from the System pop-up list.  Choose “56” from the Zone pop-up list.  Click on OK.

4. Click on the point selection tool:   .  Click on the image to bring it to the front.

5. Click on the image to select a point then choose Add GCP from the Image menu.  The selected
point is assigned a number and is listed in the Ground Control Points dialog.  Repeat step 4 to
add an additional three points to the GCP model.

6. Click on the Ground Control Points window to bring it to the front.
You can now specify the map coordinates that each GCP is to be mapped to.  Click on a GCP in
the list.  Note that the image and actual coordinates of the current GCP are also displayed in the
boxes below the GCP list under the Image and Actual columns.  For the x and y image coordinates



DIMPLE 3.0 Demonstration Guide Page 17

of the GCP, specify the actual AMG coordinates (in metres) by typing the values in the boxes
under the E and N columns (any values will do for the example).  Repeat step 6 for all GCPs.

A GCP model is supplied on the demo CD for the Jervis Bay image.  Choose Open from the File
menu, and then select the file “Jervis Bay GCPs.DGC” (Macintosh) or “JBGCP.DGC” (Windows).
The GCP model will be displayed in the GCP window.

7. Click on the Linear button to select a first order polynomial to be used in the mapping.

8. Click on Model.  A mapping polynomial is determined using the image and actual coordinates
of the GCPs.  This polynomial is then applied to the image coordinates of the GCPs and the
results listed under the Estimated columns.  The residual, or difference between the values
estimated by the polynomial and the actual values you specified, are listed under the Residuals
columns (if these columns are not visible use the scroll bar at the bottom of the GCP list).  The
mean of the residuals is displayed at the bottom of the window.  From this information you can
determine how good the model is.

Detecting outliers

9. You can look for outlier GCPs by excluding them from the model temporarily.  Click on the space
to the left of the GCP number of the GCP you wish to exclude.  A “ ” appears indicating the
GCP is to be excluded.  Click on Model.  Notice the difference in the estimated map coordinates
and residuals.  To include the GCP in the model again, click on the “ ” so that it disappears.  To
delete the current GCP from the model altogether choose Clear from the Edit menu.

❖ Note:  the GCP window is also used for image to image registration.  In this case you have
a master image, which is already registered.  You collect a GCP on the image to be registered
as in steps 4 and 5.  Then instead of typing its map coordinates for the Actuals in the GCP
dialog, you select a point (Relative Control Point or RCP) on the master image that
corresponds to this GCP, and choose Set RCP from the Image menu.  The coordinates of
the Relative Control Point (RCP) on the master image are then placed into the Actuals for
the slave image GCP.

DIMPLE can also automatically locate RCPs - click on a GCP in the GCP window, then
select a small area on the master image using the rectangular area selection tool, and choose
Auto locate RCP from the Analyse menu.  DIMPLE will find the most likely RCP in the
master image corresponding to the selected GCP in the slave image.

GCP model report

10. Choose Report from the File menu then Ground Control Points from the submenu to produce a
GCP model report.  Scroll through the report to see details of the GCP model.  Note that the
mapping polynomial is displayed for both the image-to-map and map-to-image transformations.

Resampling the image

11. Click on the image to bring it to the front.  Choose Resample from the Image menu.

12. Click on the Rectification model pop-up list.  As well as GCP-based registration, DIMPLE provides
several mathematical rectification models.  Choose Current GCP model.

Note that the Coordinates system for the output image reflects that of the GCP model.  The
bounds of the input image are mapped to their estimated map coordinates using the GCP model
and appear in the boxes labelled Output image bounds.
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13. Specify that the output image is to have a pixel size of 50 by 50 (AMG metres).

14. Choose a resampling method.  Nearest neighbour is suitable for images which are to be used for
further analysis.  For photographic images, Bilinear and Cubic will produce visually smoother
images, but these methods are slower than nearest neighbour.

15. Click on Resample.  There will be a wait of a minute or so while the resampling takes place.

16. Observe the output registered image.  Move the cursor over the image and note that both image
coordinates and map coordinates are displayed in the info window at the left of the screen and
that the image origin is in the bottom left of the registered image.

17. Choose Image Details from the Image menu to see the details of the registered image.  Click on
OK.

18. Choose Close all from the File menu when finished.

10. Gridding & Interpolation

This example demonstrates importing point file data, and performing gridding and interpolation of
this data to produce images for analysis.  An example of part of a point file containing geochemical
data is:

E,N,Zn,Pb,Cu,Fe,Mn
338325,8089966,12.6,19,17.4,2.9,39.9
337494,8089988,27.2,14.4,39.3,7,187.7

Each line represents one drill hole sample.  The first two numbers are the map grid coordinates of the
grid hole, and the remaining numbers represent the chemical analysis of that sample.  The first line in
the file is a header describing the layout of the data in the rest of the file.

DIMPLE can import a file like this and produce a raster image, with values interpolated to fill the
gaps between samples.  It can also produce a vector image to show the location of the samples.

1. Choose Open from the File menu, and select the file “Geochem.dat”.  This file contains some
simulated geochemical data.

2. From the Image File Format dialog box, choose “Custom point file” as the file format.  Click on
Open.

The first dialog box which appears asks you to specify the format of the data in the file.

At the top of the dialog box, a line of data from the file is displayed.  Click on the arrows:  to

see the next or the previous line.  Click on the return button:  to return to the first line in the
file.

This file uses commas to separate fields, so choose “Single comma” from the Field separator
pop-up list.

The first line of the file is a header, so specify Skip first [1] line.  Because this line contains the
names of the channels, check the “Read channel names from line 1” box.
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Next, we specify in what columns in the file the fields of data are located.  The X and Y coordinates
are located in columns 1 and 2.  The Values for Zn, Pb, Cu, Fe, Mn are located in columns 3 to 7,
so type “3 4 5 6 7” to indicate that we want to produce images for all of these.

The data file uses the value -1E30 for Null - i.e. to indicate that a sample is not available.  The
specify this, choose “Single special value” from the Nulls pop-up list, and then type “-1E30” in
the box next to it.

When you have specified all these parameters, Click on OK.

3. The next dialog box allows you to specify parameters for the gridding and interpolation process.

First, the Coordinate system for this example will be Projected, AGD84/AMG, Zone 49.
The origin for this coordinate system is the bottom left of the image.

An appropriate Pixel size for this example will be 100 x 100 metres.

Multiple samples indicates how DIMPLE will handle the situation in which there are multiple
samples of data for the same point.  Choose “Weighted Average”.

For the Output data type, choose “32 bit real” - the output images will contain values
corresponding to the chemical analyses of the data.  An 8 bit integer image would represent the
analyses as values between 0 and 255, and although the colours would be meaningful, the original
values would be lost.  Other integer types would be suitable if the data being sampled was
integer data.

For Stretch for display, choose “Gaussian 3sd”.

Interpolation determines how pixels between samples will be filled in.  The Search radius specifies
how far from each “empty” pixel in the output image DIMPLE will search for neighbouring
pixels.  An appropriate value for this example is 6.

The Smooth iterations and Smooth radius determine how filtering is applied to the interpolated
pixels to produce a smooth output image.  For this example, choose 3 Smooth iterations and a
Smooth radius of 3.

Click on OK.

4. Look at the individual channels to see how the gridding and interpolation process has produced
raster images.  As you move the pointer over the image, the analysis values are displayed in the
Info window, as is the pixel graph of the values in each channel.

5. We will now produce an RGB colour composite of three channels.  Choose RGB from the Transform
menu, and choose a channel for each colour - e.g. Pb for Red, Cu for Green, and Zn for Blue.
Choose a 24-bit image.  We will use the stretches currently applied to the images (i.e. Gaussian)
to produce the colour composite, so leave the Stretch pop-up lists as “Current”.  Click on OK.

The different colours in the image represent different combinations of the three elements.

6. A useful tool in analysing the colour composite images produced from gridded data is the Image
cross plot.  Choose Cross plot from the Analyse menu, and then Images from the submenu.

For Image X and Image Y, choose two of the three channels which you used for the RGB colour
composite - e.g. Cu and Zn.  For Colour, choose the RGB image.

The scatter plot shows the colours that represent various combinations of the two elements in the
RGB image.
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You can also produce vector images from point file data.  In this example, we will produce a vector
image which will show where the drill samples were taken.
7. Choose Open from the File menu, and again select the file “Geochem.dat”.

8. From the Image File Format dialog box, choose “Custom point file” as the file format.  This time,
click on Read as vector to indicate that you want to produce a vector rather than a raster image.
Click on OK.

9. The point file format dialog appears, with the settings above still shown.  This time, we only
want one image produced, so change the Values to one of the channels - e..g “3”.  Click on OK.

10. The next dialog box allows you to specify parameters for producing the vector image - the scale
at which it will be displayed by default, and the symbol to be used for the points.

Choose a “+” for the symbol Through the point, nothing for the symbol Around the point, and
the medium size for Size.  A preview of the point style is shown on the dialog box.  Click on OK.

11. We will now overlay the vector image onto the RGB raster image we produced earlier.  Bring the
RGB image to the front, and choose Image overlay from the Annotation menu.  From the Add
vector pop-up list, choose the newly-created vector image.  Click underneath Colour to specify a
colour to draw the vectors in.  You can also change the point style used to draw the points on the
image.
Click on OK, and the vector image is drawn on the RGB image.  You can zoom in for a more
accurate view of where the drill hole points are located.

Choose Quit from the File menu when finished.
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